834: TREE lost on non-focus panel

Bugs and issues - current donor version.
Post Reply
Message
Author
dsperber
Posts: 187
Joined: 28.03.2010, 01:35

834: TREE lost on non-focus panel

#1 Post by dsperber » 05.12.2020, 00:03

Don't know if this occurs for LEFT/RIGHT split-screen view, but it absolutely is happening for me with TOP/BOTTOM split-screen view.

I have "one tree per panel" checked for both (a) File System tree, and (b) Favorite Items tree.

Here's how to demonstrate the failure. Again, TOP/BOTTOM spit-screen view. And TREE enabled for both panels.

(1) split the screen (F10) to get TOP/BOTTOM two panels. And be sure each panel has two panes, i.e. both TREE as well as DETAILS. So four panes on the screen. Click on the Address Bar of the upper panel, just to give it the focus for this demonstration.

(2) close the program, and re-launch. There will still be two panels (TOP/BOTTOM) and the bottom panel (that does NOT have the focus) will get painted visually in two steps. If you look at the bottom half of the screen when you launch the program you will notice that initially there is NO TREE (i.e. the DETAILS pane initially occupies the entire width of the program window), and then TREE appears (i.e. the DETAILS pane shrinks to make room for the TREE pane on the left). There is a very visible brief time between the initial absence of the TREE pane and then the appearance of the TREE pane, in the non-focus panel.

In fact, this time-delay in the non-focus panel between the absence and then presence of the TREE pane is visible no matter whether the non-focus panel is at the top or bottom of the screen. Whichever panel is the non-focus panel, when the program is launched the TREE pane for that non-focus panel is initially ABSENT and the DETAILS pane occupies the entire program window width. And then a moment later the DETAILS pane shrinks and the TREE pane appears. This behavior in the non-focus panel on program launch is 100% consistent.

(3) With the program open and split-screen mode in effect, select the Address Bar of either the top or bottom panel in order to give it focus. Then toggle back to single-panel (non-split) mode using F10. So now there is only that one panel in the program window. Now close the program.

(4) Re-launch the program. Still only the one panel with focus. Now use F10 to toggle back to split-screen mode, to present the bottom panel as non-focus. THERE IS NOW ONLY THE DETAILS PANE IN THE NON-FOCUS PANEL! NO TREE!!

(5) With the program still open, use F10 to toggle out of split-screen mode. Then F10 again to toggle back into split-screen mode. NOW THE TREE PANE HAS RE-APPEARED. Toggling back and forth with F10 now the TREE pane is always present in the non-focus panel.

(6) Again, use F10 to get out of split-screen mode and into single panel mode. Now close the program, and re-launch returning still in single-panel mode. Now F10 to split the screen, getting no TREE in the non-focus panel. Now select the Address bar in the non-focus panel, to give it the focus. Now ALT+T to toggle the TREE pane (which should make it appear if not present, or make it disappear if present). Well nothing happens!! It is as if FCXE believes the TREE IS CURRENTLY PRESENT (even though it is currently not visible!), as if it were being "toggled OFF".

Now repeat ALT+T, and magically the TREE appears. The first ALT+T had no effect probably because FCXE wasn't aware there actually was no visible TREE on the screen even though it was supposed to be. But theoretically it has now been disappeared. And so the second ALT+T now brings it back, and it is truly visible.


==> If the program window is in single-panel non-split mode when the program is closed, when the program is re-launched and F10 used to split the screen, the now visible second panel that does not have the focus is missing its TREE pane. This is true even if ALWAYS SHOW TREE IN EACH PANEL is in effect, and even if the TREE pane was visible in that non-focus panel the last time split-screen was in effect.

Marek
Author
Author
Posts: 3142
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: 834: TREE lost on non-focus panel

#2 Post by Marek » 05.12.2020, 16:47

Thanks for the detailed description.
I can reproduce it.
It is fixed for the next release.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests