653 - some folders are not extracted correctly from zip's

Bugs and other issues or requests which have been resolved.
Post Reply
Message
Author
joby_toss
Posts: 1346
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

653 - some folders are not extracted correctly from zip's

#1 Post by joby_toss » 16.02.2014, 11:00

All FC XE used were portable versions with default settings, on win7x64sp1:

- public 650 -> everything is fine:

Image

Image

- beta 653 (both 32 and 64 bit versions) -> one folder is extracted with its full path and empty (don't understand why):

Image

Image

Test archive (portable PicPick version from Softpedia): http://www.softpedia.com/progDownload/P ... 29883.html

User avatar
ralfso
Posts: 707
Joined: 31.10.2007, 17:21
Location: Gifhorn, Germany

Re: 653 - some folders are not extracted correctly from zip'

#2 Post by ralfso » 16.02.2014, 12:37

Confirmed, if I want to extract subfolders from the zip-file only empty folders are extracted.
Also tested with a fresh created zip-file or another zip-file.
Extracting the complete zip-file works fine.

v 653 (x64)
Regards
Ralf

Win10 (64-bit), Intel i7-2600 (3,4 GHz), 8 GB Ram, 500 GB SSD, 2x2000 GB HD, NVIDIA GeForce 545

Timon
Posts: 688
Joined: 13.09.2012, 06:51

Re: 653 - some folders are not extracted correctly from zip'

#3 Post by Timon » 16.02.2014, 13:06

Confirmed in FC XE 653 under Windows XP 32 bit.

Extracting the complete archive works fine.

BUT if we want to make partial extraction (for example, only 1 folder - resource), then only empty folders are extracted.

What is more
We try to extract folder PicPick.zip\PicPick\resource
after extraction we get 2 folders with subfolders
<EXTRACTION FOLDER>\PicPick\resource
<EXTRACTION FOLDER>\resource\frame
<EXTRACTION FOLDER>\resource\watermark

joby_toss
Posts: 1346
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

Re: 653 - some folders are not extracted correctly from zip'

#4 Post by joby_toss » 16.02.2014, 13:28

Thanks for checking, guys!

horst.epp
Posts: 155
Joined: 15.11.2008, 19:18

Re: 653 - some folders are not extracted correctly from zip'

#5 Post by horst.epp » 16.02.2014, 15:55

The error even happens when only an archiver plugin (Total7zip) is used for zip archives.
So the error is in the internal FCXE code for handling of archive subfolders.
FCXE x64 build 653.

joby_toss
Posts: 1346
Joined: 22.07.2009, 19:19
Location: Romania
Contact:

Re: 653 - some folders are not extracted correctly from zip'

#6 Post by joby_toss » 04.03.2014, 20:58

Fixed in beta 654. Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests