Page 2 of 2

Re: Own copy function for better performance

Posted: 18.03.2012, 21:22
by fallout33
joby_toss wrote:I've just tested version 0.3.0.3 portable and it works (intercepts) with FC XE 581 and FC 2009.02b.418 using Ctrl+C/Ctrl+V commands, on my win7x64sp1 (just like yours ;) ).

The command line syntax should look like this:

Code: Select all

ultracopier cp [folders/files] [destination folder]
[...]
Thank you for testing.

It is very interesting, that it works for you, but not for me :)

I have tried both, the normal installation of Ultracopier 0.3.0.3 and the portable version which you have postet.

For both, the copying does not work. Instead, only a copy list (.tmp file) is created in the windows temp directory which contains the path of the file which I tried to copy. And no, I did not use the "Copy" command line parameter for Ultracopier (copy list) but "cp".

Code: Select all

FileCopyPrg=C:\Program Files (x86)\Ultracopier\ultracopier.exe cp %ActivSelAsFile% %InactivDir%

Re: Own copy function for better performance

Posted: 19.03.2012, 00:43
by inglorious
joby_toss wrote:FC XE already supports 3rd party transfer tools, we just need to know their command line options:
thanks, I somehow missed that setting.

Re: Own copy function for better performance

Posted: 19.03.2012, 05:27
by joby_toss
fallout33 wrote:Thank you for testing.
No problem!
It is very interesting, that it works for you, but not for me :)
It even works for copy commands when using right mouse button drag and drop menu.
I can make a video demo if necessary.
I'm always admin on my PC and I have UAC permanently disabled.
And no, I did not use the "Copy" command line parameter for Ultracopier (copy list) but "cp".
I used none. No settings were changed in my FC .ini files.
Ultracopier worked by itself (also, no settings changed in UC settings).
Note that UC did not intercept copy/move commands given in FC using F5/F6 or Shift+F5/Shift+F6 (only Ctrl+C/Ctrl+V and drag&drop were intercepted). For this to work, we need to find the correct command line commands for UC.

Re: Own copy function for better performance

Posted: 05.06.2012, 20:21
by fallout33
joby_toss wrote:[...] No settings were changed in my FC .ini files [...] Note that UC did not intercept copy/move commands given in FC using F5/F6 or Shift+F5/Shift+F6 (only Ctrl+C/Ctrl+V and drag&drop were intercepted). For this to work, we need to find the correct command line commands for UC.
The UltraCopier parameters were clear but the correct FreeCommander variables have been the critical point.

I solved the problem by using the ActivSel variable instead of ActivSelAsFile which was mentioned several times in this thread.

Code: Select all

FileCopyPrg=C:\Program Files\Ultracopier\ultracopier.exe cp %ActivSel% %InactivDir%
FileMovePrg=C:\Program Files\Ultracopier\ultracopier.exe mv %ActivSel% %InactivDir%
Now, the copying and moving with UltraCopier using the F5 and F6 keyboard shortcuts works as expected.

Re: Own copy function for better performance

Posted: 06.06.2012, 12:20
by joby_toss
It works, yes!
Thanks!

P.S. Latest Ultracopier can be found here.

Re: Own copy function for better performance

Posted: 06.06.2012, 17:17
by fallout33
fallout33 wrote:[...] I solved the problem by using the ActivSel variable instead of ActivSelAsFile which was mentioned several times in this thread.

Code: Select all

FileCopyPrg=C:\Program Files\Ultracopier\ultracopier.exe cp %ActivSel% %InactivDir%
FileMovePrg=C:\Program Files\Ultracopier\ultracopier.exe mv %ActivSel% %InactivDir%
[...]
The double quotes around the variables have been deliberately omitted because they caused UltraCopier to claim that the source and destination are the same. The drawback is that now only files and directories can be copied/moved from/to which do not contain any space characters.

However, copying/moving a file where the source/destination path contains space characters with UltraCopier from the command line does work.

Re: Own copy function for better performance

Posted: 06.06.2012, 17:47
by joby_toss
Dealing with paths containing spaces works for me if I use quotes on InactivDir parameter:

Code: Select all

...ultracopier.exe cp %ActivSel% "%InactivDir%"

Re: Own copy function for better performance

Posted: 08.06.2012, 10:43
by fallout33
joby_toss wrote:[...] Dealing with paths containing spaces works for me if I use quotes on InactivDir parameter [...]
It only works if the source path does not contain any spaces - that's a 50% improvement in comparison to the previous situation :)

Re: Own copy function for better performance

Posted: 08.06.2012, 12:01
by joby_toss
For me it works OK even if both source and destination paths contain spaces.

Re: Own copy function for better performance

Posted: 10.06.2012, 21:06
by fallout33
Which version of FreeCommander are you using?

I'm using 2009.02b.

Re: Own copy function for better performance

Posted: 10.06.2012, 21:30
by joby_toss
FC XE 594. I thought you're using XE too, since this is the beta discussion sub-forum.

Re: Own copy function for better performance

Posted: 11.06.2012, 21:17
by fallout33
joby_toss wrote:[...] I thought you're using XE too, since this is the beta discussion sub-forum [...]
(In my first posting in this thread I have already mentioned that I am using the stable version.)
Despite the version difference I have chosen this thread because it was the best fitting one (topic was not discussed elsewhere).